Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Make sure to check out our Community Guidelines

Please be a good neighbor, treat others with respect and patience.
Make friends!

-FrostWire Team

Frostwire Searching OK but not Downloading!


This is strange. I've installed the latest Frostwire v6.4.4. (just incase it fixes the issue) and I can search okay without any problems but I cannot download anything.

Its been like this for 2 days now.

I've double checked the PCs firewall (even disabled it) and I can search and select something to download but in the Transfers window it just sits there on "Downloading" and not picking up any seeds, even though there are thousands seeding.

I've also tried port forwarding the router (which I have never needed to before) and this has no effect.

I have uninstalled and reinstalled, temporarily switched off the firewall, tried port forwarding but nothing seems to allow me to download a thing.

I have not installed anything for weeks and there are no other applications which I can see which would effect Frostwire.

Normal internet browsering works fine and no issues there.

Is there anything else I can try ?


  • I have been having exactly the same problems since the new improved version was downloaded . Previously everything worked fine .

    In addition many of the links take you to pay sites rather than to a file .... What has happened to Frostwire ... it was always so good . :(

    Are there any solutions to these problems ?
  • Having the same issues here, as well. Can't download anything. Just stuck on "downloading." Previous version worked fine. What's going on?
  • So glad its not just me. Been happening to me for a while now. It's just stupid. The only thing that works is the crafty malware that gets loaded.

Leave a Comment