Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Make sure to check out our Community Guidelines

Please be a good neighbor, treat others with respect and patience.
Make friends!

-FrostWire Team

Frostwire 6.3.5 locks up after entering artist to search

Running Windows 7, Microsoft Security Essentials, & Malwarebytes Anti-Malware.

The program takes a long time to load. When I hit enter after typing an artist to search for, Frostwire locks up. Can't close the program down, and when I hit minimize and then bring the Frostwire window back up, the window is black. I have to close frostwire using task manager.

I have downloaded and installed FW 6.3.5 three times after uninstalling the program each time with the same lock up result. I have gone into MSE and allowed the program to run. The last Frostwire Version that worked was 6.1.8, but I can't seem to find a good previous version on the Frostwire website or anywhere else.

This is really getting annoying. I would appreciate any help you can give. Thanks

Dave Olenyik


  • thank you for such a detailed report Dave!

    could you please help us a bit further to find the root of the problem?

    Please run FrostWire with the Safe-Mode launcher, you will see a terminal window in the background.
    Perform a search so it freezes, and once it does, please copy and paste all the output on the window here, perhaps we'll be able to see what's causing the freeze.
  • you can talk to us live via Slack. You can join our slack at (Get Invite) if you haven't already
  • Hi there, please try this installer and let me know if the search issue is gone.
    This is an internal build for FrostWire 6.3.6, we fixed several issues with search, and lots of changes on the bittorrent engine that may have fixed your freeze ... -build-201
  • I have used Frostwire for many years and everything worked fine until downloading the latest 6.3.5 version. As soon as I load it and click on the transfer tab the program will lock up and you cannot get out of it unless you use the task manager. I tried the suggested 6.3.6 and it did not change a thing. I uninstalled the program and went back to a later one 6.1.4 and it worked just fine. In the older version it took just a few minutes for it to check your files you have paused, but now it takes more then 10 or 15 minutes for it to check files sometimes even longer. While it is checking you can't do anything with the program, not even x out of it.
  • thank you for this insight.

    Again, if you ever have the time, try 6.3.6 and send us some logs, it's really the only way we can see what the issue is as we cannot replicate it in any of our testing computers.
  • I have installed Frostwire 6.3.6 and it too locks up after typing anything into the search box. I had to uninstall it and reinstall 6.1.4.
  • I have tried the 6.3.6 version of Frostwire and it still will lock up. I uninstalled it and went to a later version 6.1.8 and it works just fine. Is there a version just before 6.3.5 available. I can't remember what the last one was just before I updated to 6.3.5 but I do know it also worked fine.

Leave a Comment