Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Make sure to check out our Community Guidelines

Please be a good neighbor, treat others with respect and patience.
Make friends!

-FrostWire Team

Downloaded data disappears

Hi - can anyone help me.

i have been using frostwire for kindle fire hd for about 9 months with no issues until last week. i downloaded 3 films and they were all 100% complete but when i got home and tried to transfer them to my PC there was only data in 1 of the 3 torrent data folders - the other 2 were blank.

I tried again to download the films and both were successfully downloaded. When i switched my device on later both were now showing only about 95% complete and required further downloading to complete. When I got home and tried to transfer to PC again both torrent data folders were empty. My storage on the device is showing them as not there. To further confuse matters the 1 film that had successfully downloaded on friday started downloading again as it was now only about 50% complete.

Can anyone explain why my data is disappearing and what I do to stop this?

I am using v1.4.2 build 155 if that helps. I keep getting messages telling me that it has downloaded an update but it won't install as there is an application with the same name running.


  • Hi - I have posted 2 replies.

    I am not absolutely sure if Kindle supports all versions of Frostwire. I think it does, but the latest version is 1.5.7.

    I did have exactly the problem you describe with several earlier versions. I simply had to copy transfers to my PC as soon as they completed downloading. What happened next to the downloaded version on my phone was a matter of luck..... but to date I have not had this problem with 1.5.7.

    This is available from Google Play Store in it's basic version, or if you wish to have Youtube compatibility, the plus version from

    As I say, I am not familiar with any particular issues with Kindle, but please up date your version and let us know if it solves the problem and please let us know how you get on!
  • I failed to notice you are having trouble updating. The following works for me using UC Browser on my Samsung Phone.
    I think the installed browser will not allow it.

    "Visit Tap Get The APK. Tap on Download wait until a message comes up and quickly click install. Complete action using Package installer > Just once. You will then get a message: Install Blocked - Tap settings and scroll down to Unknown Sources and check the box. Check allow initial installation only (for your safety, so you do not inadvertently download malicious apps in future) click OK. Then tap install - not sure if it matters if you choose New or All btw.

    It is a slight pain . Google don't like you getting non Play Store apps but useful for any app they do not have, and I find UC a cool browser anyway."

    I hope this helped.

    If you are not interested in Youtube downloads the process is simpler from the Playstore, but again I am not sure of the differences in Kindle if any.
  • thanks for the info. I am unable to download it from the play store - kindle runs a bespoke Android OS I think and it is limited to what you can install. I got the app originally from amazon but it is not there anymore.

    I took a memory stick and just transferred the stuff as soon as it downloaded and for some reason it seemed to have solved the problem. The data has remained there ever since. Hopefully it was just a temporary glitch.

    Thanks again
  • Just a friendly correction: there is no YouTube compatibility on neither the Play Store nor the APK Plus version.
  • Hi roonch,

    I have not used Frostwire for a few days but have just updated my APK plus version to 1.5.8 and YouTube is working fine. The previous version might not have been working.

    Frostwire is aware that the PlayStore version is not YouTube compatible. This was a condition of having Frostwire available on PlayStore - hence the introduction of Frostwire plus.

    I hope the new version works for you.

    Do ensure YouTube is checked in Settings>Search Settings

Leave a Comment