Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Make sure to check out our Community Guidelines

Please be a good neighbor, treat others with respect and patience.
Make friends!

-FrostWire Team

can't connect with old versions

I do not like the new versions of frostwire so I downloaded a couple older versions. None of them will connect to the internet, but all of the newer versions will. I've tried port forwarding, disabling my firewall completely, disabling my anti-virus, and changing the ports frostwire listens on. I have uninstalled and reinstalled, and used a microsoft tool to remove all associated files and still no luck. I am using windows xp service pack 2 with framework 2.0. I will be grateful for help in resolving this matter. Thanks in advance.


  • Would suggest using the latest release of the Gnutella version,4.21.8, which can be found here. (WIndows)

    There are tips & tricks for the Gnutella version(s) posted here and here to help combat the spam on the network.

    For connection issues, see the sticky here,mainly the part about the file.

    To show all results; In Frostwire, go to Tools > Options > FIlters > Junk - tick 'Display Junk at the Bottom of Search Results' and move the slider bar to a lower level ( i keep mine about the middle ), then retry your search query.

    You can also right click the Search tab > Search More > Get More Results.

    Hope that you find this information helpful. :)

Leave a Comment