upnp doesn't work

The worlds first mobile WiFi Peer-2-Peer filesharing app!
doongorm
Member
Posts: 4
Joined: Sat May 18, 2013 5:03 am

upnp doesn't work

Postby doongorm » Sat May 18, 2013 5:21 am

Hi,

upnp mapping doesn't seem to work on my router from frostwire android client. I can see mapped port from desktop frostwire client, but there is no mapped port from mobile device, though downloading works (apparently, direct download from tracker or something but not from other client behind NAT).
Mobile device is connected to the wi-fi and has ip of local network - 10.0.0.2.
How can it be fixed (without manual mapping of the port on router)?

Scott1x

Re: upnp doesn't work

Postby Scott1x » Sat May 18, 2013 10:17 am

doongorm wrote:Hi,

upnp mapping doesn't seem to work on my router from frostwire android client. I can see mapped port from desktop frostwire client, but there is no mapped port from mobile device, though downloading works (apparently, direct download from tracker or something but not from other client behind NAT).
Mobile device is connected to the wi-fi and has ip of local network - 10.0.0.2.
How can it be fixed (without manual mapping of the port on router)?

I can only think of one way to fix it.. a new router.
I'm surprised that it is in the 10 range. I'm used to seeing the 19x range. My vpn grabs the 10 range.
Why not just manually map it? I have my listening port specified and mapped for each computer on my network. I don't depend on UPnP for FrostWire.
I locked the IP selection for the devices that use FW to keep it simple.

doongorm
Member
Posts: 4
Joined: Sat May 18, 2013 5:03 am

Re: upnp doesn't work

Postby doongorm » Sat May 18, 2013 10:36 am

Router seems to be fine - other torrent programs, also desktop version of frostwire work fine - ports are mapped automatically,
so I think this is not the router issue. 10 - just default internal range in default router configuration from the provider.
I can manually map ports on my router, but I'll use the frostwire as a part of a bigger project in environments where I can't change the configuration of routers or firewalls.
So I must stick with upnp. So, any thoughts?
And, by the way, how I can configure the port on android version of frostwire?

Thanks,

Scott1x

Re: upnp doesn't work

Postby Scott1x » Sat May 18, 2013 11:15 am

doongorm wrote:Router seems to be fine - other torrent programs, also desktop version of frostwire work fine - ports are mapped automatically,
so I think this is not the router issue. 10 - just default internal range in default router configuration from the provider.
I can manually map ports on my router, but I'll use the frostwire as a part of a bigger project in environments where I can't change the configuration of routers or firewalls.
So I must stick with upnp. So, any thoughts?
And, by the way, how I can configure the port on android version of frostwire?

Thanks,

I'm never used an android device, so I'm not going to be much good there. You are in the right section, but I'd suggest reposting and titling it as android help with UPnP or something like that to get the attention of the developers. This could be an android version problem. I'll be careful to NOT respond and take if off the "new" list!


Return to “FrostWire Mobile Technical Support”

Who is online

Users browsing this forum: No registered users and 3 guests