Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Expect a bit of breakage the following days as we adjust to this new platform.

We thank you for your patience.
-FrostWire Team

Search screen freezes

When I open Frostwire I find everything either freezes or lags very badly. When I do a movie search I get ZERO responses and I can't delete previous searches...other than that it's working great. :neutral:

I have the current version 6.6.2 (Build 251).
I run on an Windows 8.1, 64 bit with an Intel i3-4005U processor running at 1.70 Ghz.
Avast virus checker
Frostwire is allowed through firewall as a private connection (is that sufficient?)
Broadband by wifi

Any clues as to what might be causing me problems?

Comments

  • Hi!

    Try a fresh installation from scratch to see if the problem gets solve:

    1) Clear all files from the Transfer list and uninstall FrostWire from Control Panel as you would do it normally

    2) Check the folder named 'FrostWire' has all your downloads, then move them to a different location and change the name of that folder to avoid confusions when installing FrostWire again.

    3) Go to 'Programs Files' or 'Program Files (x86)' or 'main_user' folder and delete any folders named '.FrostWire5' and/or '.FrostWire6', make sure there is no any other similar folder within other route named 'Program Files' or within any other folder where you installed FrostWire previously.

    4) Go to http://www.frostwire.com/downloads and get FrostWire 6.6.2, launch the installer and let us know If it finally works.

  • since your CPU is not the strongest, I'd also recommend doing only 1 search at the time.

  • Thanks to Alexm & gubatron for the replies and apologies for the length of time replying.

    Finally able to delete all files from transfer list. Took about 20 minutes but worth the wait. Cleared all the program files and then did a full re-install. After the re-install I still got a hell of a delay before any search populates the screen BUT I am now able to do single searches with decent return results. I'll put this down to my slow CPU.

    Thanks to you both for the assistance.

  • glad to be of help, we're doing everything we can on every release to make the app perform better

Leave a Comment