Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Make sure to check out our Community Guidelines

Please be a good neighbor, treat others with respect and patience.
Make friends!

-FrostWire Team

FrostWire 6.3.1

edited January 2017 in Open Discussion
Just a couple of points.

6.3.1 does work with Windows XP even though the System Requirements on the following page no longer list it:

And on the FrostWire GUI under Tools, it shows You are up to date with FrostWire v.6.3.0 (even though Help>About shows 6.3.1).

No problems apart from that.


  • Shot in the dark did you tried running it in compatability mode ?

    I'm going to try with my virtual windows xp
    when I get around to it.

    Let know what's your results are


Leave a Comment