Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Expect a bit of breakage the following days as we adjust to this new platform.

We thank you for your patience.
-FrostWire Team

How to download .torrent files with FrostWire (BitTorrent)

Check this short video tutorial to learn how to download content with .torrent files using FrostWire
http://www.youtube.com/watch?v=6mGLUe7LhxQ

Tips for faster downloads:
* Free some of your bandwidth by disconnecting from Gnutella when you're downloading a torrent (Files -> Disconnect)
* Download one torrent at the time
* The more you give, the more you receive. Raise the number of Maximum uploads per torrent on Tools > Options > BitTorrent > Advanced
«1

Comments

  • Hi, I installed a fresh system and Frostwire latets version. Using the Search function inside Frostwire, I can download files for which sources are consequently found. However if I download torrents from any of multiple sites they do appear in Frostwire but for none of my torrents any sources can be found (waiting for sources / need more sources) ?? A few weeks ago there was no such problem. Why is this, does anyone else have this problem too ?? Thnx.
  • what operating system are you running? what Java version does frostwire show on the About Dialog?
  • twitty90 wrote:
    Hi, I installed a fresh system and Frostwire latets version. Using the Search function inside Frostwire, I can download files for which sources are consequently found. However if I download torrents from any of multiple sites they do appear in Frostwire but for none of my torrents any sources can be found (waiting for sources / need more sources) ?? A few weeks ago there was no such problem. Why is this, does anyone else have this problem too ?? Thnx.
    I have been having the exact same problem.
    I use Mac OS X and Frostwire's java version is 1.5.0_16.
  • same here! i have the exact same problem! I can use frostwire to search and download songs and it works like a charm. But ever since i updated frostwire to the new version, the torrent downloading has been useless. And it's not a matter of seeding, there isn't a single torrent file out there that will work with frostwire right now. what gives?
  • It's really driving me crazy :(
  • so how do we resolve this problem? any takers?
  • I'm really not sure why this might be happening.

    Are you sure you're running 4.18.3?

    We tested on both Leopard and Snow Leopard and we can download torrents just fine.

    Check on the About window of FrostWire which version of Java it's actually using. You may have several versions of Java installed in your machine but FrostWire decides which one to use based on the information of it's Info.plist file. You may want to edit that file inside your FrostWire.app folder to tweak the Java version FrostWire uses, maybe switching to another version of Java will solve the issue.

    I'd also try wiping out downloads.dat, or the contents of my Incomplete folder, maybe there's something that went wrong there which is not letting your torrent downloads work.
  • yes, i am using frostwire version 4.18.3

    the java version says 1.5.0_19

    my mac is OS X vers 10.4.11


    -and also, i just cleared out my incomplete folder and still nothing... I tried to change the version of java, but i'm having trouble finding the folder to do that. how do i do that exactly?
  • $ cat /Applications/FrostWire.app/Contents/Info.plist
    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <plist version="1.0">
      <dict>
        <key>CFBundleName</key>
        <string>FrostWire</string>
        <key>CFBundleShortVersionString</key>
        <string>1.0</string>
        <key>CFBundleGetInfoString</key>
        <string>1.0</string>
        <key>CFBundleAllowMixedLocalizations</key>
        <string>false</string>
        <key>CFBundleInfoDictionaryVersion</key>
        <string>6.0</string>
        <key>CFBundleExecutable</key>
        <string>JavaApplicationStub</string>
        <key>CFBundleDevelopmentRegion</key>
        <string>English</string>
        <key>CFBundlePackageType</key>
        <string>APPL</string>
        <key>CFBundleSignature</key>
        <string>FROS</string>
        <key>CFBundleVersion</key>
        <string>4.18.1</string>
        <key>CFBundleURLTypes</key>
        <array>
          <dict>
            <key>CFBundleURLName</key>
            <string>Magnet</string>
            <key>CFBundleURLSchemes</key>
            <array>
              <string>magnet</string>
            </array>
            <key>CFBundleURLIconFile</key>
            <string>FrostWire.icns</string>
          </dict>
        </array>
        <key>CFBundleIconFile</key>
        <string>FrostWire.icns</string>
        <key>CFBundleDocumentTypes</key>
        <array>
          <dict>
            <key>CFBundleTypeName</key>
            <string>Torrent File</string>
            <key>CFBundleTypeRole</key>
            <string>Editor</string>
            <key>CFBundleTypeIconFile</key>
            <string>FrostWire.icns</string>
            <key>CFBundleTypeExtensions</key>
            <array>
              <string>torrent</string>
            </array>
            <key>CFBundleTypeMIMETypes</key>
            <array>
              <string>application/x-bittorrent</string>
            </array>
          </dict>
        </array>
        <key>Java</key>
        <dict>
          <key>MainClass</key>
          <string>FrostWireLauncher</string>
          <key>JVMVersion</key>
          <string>1.5.0</string>
          <key>ClassPath</key>
          <array>
            <string>$JAVAROOT/FrostWire.jar</string>
            <string>$JAVAROOT/MRJAdapter.jar</string>
            <string>$JAVAROOT/ProgressTabs.jar</string>
            <string>$JAVAROOT/aopalliance.jar</string>
            <string>$JAVAROOT/clink.jar</string>
            <string>$JAVAROOT/commons-codec-1.3.jar</string>
            <string>$JAVAROOT/commons-logging.jar</string>
            <string>$JAVAROOT/daap.jar</string>
            <string>$JAVAROOT/forms.jar</string>
            <string>$JAVAROOT/foxtrot.jar</string>
            <string>$JAVAROOT/gettext-commons.jar</string>
            <string>$JAVAROOT/guice-1.0.jar</string>
            <string>$JAVAROOT/httpclient-4.0-alpha3.jar</string>
            <string>$JAVAROOT/httpcore-4.0-beta2.jar</string>
            <string>$JAVAROOT/httpcore-nio-4.0-beta2.jar</string>
            <string>$JAVAROOT/httpcore-niossl-4.0-alpha7.jar</string>
            <string>$JAVAROOT/icu4j.jar</string>
            <string>$JAVAROOT/jaudiotagger.jar</string>
            <string>$JAVAROOT/jcraft.jar</string>
            <string>$JAVAROOT/jdic.jar</string>
            <string>$JAVAROOT/jflac.jar</string>
            <string>$JAVAROOT/jl.jar</string>
            <string>$JAVAROOT/jmdns.jar</string>
            <string>$JAVAROOT/jogg.jar</string>
            <string>$JAVAROOT/jorbis.jar</string>
            <string>$JAVAROOT/junit.jar</string>
            <string>$JAVAROOT/jython.jar</string>
            <string>$JAVAROOT/log4j.jar</string>
            <string>$JAVAROOT/looks.jar</string>
            <string>$JAVAROOT/lw-all.jar</string>
            <string>$JAVAROOT/messages.jar</string>
            <string>$JAVAROOT/mp3spi.jar</string>
            <string>$JAVAROOT/onion-common.jar</string>
            <string>$JAVAROOT/onion-fec.jar</string>
            <string>$JAVAROOT/themes.jar</string>
            <string>$JAVAROOT/tritonus.jar</string>
            <string>$JAVAROOT/vorbisspi.jar</string>
            <string>$APP_PACKAGE/Contents/Resources/Java</string>
          </array>
          <key>VMOptions</key>
          <string>-Xms64M -Xmx256M -Djava.net.preferIPV6Addresses=false -Djava.net.preferIPv4stack=true -Djava.library.path=. -Djava.endorsed.dirs=''</string>
          <key>WorkingDirectory</key>
          <string>$APP_PACKAGE/Contents/Resources/Java</string>
          <key>Properties</key>
          <dict>
            <key>apple.laf.useScreenMenuVar</key>
            <string>true</string>
            <key>apple.awt.textantialiasing</key>
            <string>true</string>
            <key>apple.awt.antialiasing</key>
            <string>true</string>
          </dict>
        </dict>
      </dict>
    </plist>
    

    Check what versions of Java are available on your machine and change where it says:
    <key>JVMVersion</key>
          <string>1.5.0</string>
    

    shutdown and reload.

    To see what versions of Java you have installed in your Mac OS open your "Java Preferences" (located at /Applications/Utilities/)
    You can drag around the Java versions available, the one on the top I think is the one considered the default JVM your system will try to use.

    Try previous versions and see.
  • Heh...I just updated to the latest FrostWire, and I'm experiencing the same problems. I'm running XP Home 2002, Service Pack 3 (lol), I'm using FrostWire 4.18.3 and Java 1.6.0_17. Any help? It's killing me...

    Thanks in advance!
  • The new Frostwire is fucked.It's now as good as bear share.Great support team too,just blame all the problems on inexperienced users.A month of no torrents,constant internal error messages,crashing and not letting anyone upload from me is enough.I'm done with this bogus program.And what the fuck is the deal with LET IT BE in the incoming searches??????
  • we're working on the upload issues and as soon as its fixed we'll release 4.18.5 as a hotfix release. I've also noticed the "Let it be" incoming searches, I thought maybe one of my files was matching that keyword combination, but I suppose there must be some malicious agents searching for people sharing the beatles?

    as for torrents, it works perfect over here.
  • just Need Trackers addon's Soo I can add more trackers to the file Im requesting : D
  • I'm getting the same problem... I'm running Mac OS X Snow Leopard 10.6.2, have Frostwire version 4.18.5 and it is using Java version 1.6.0_17

    I keep getting the message "needs more sources" on most of my torrent downloads. These same torrents work in the mac versions of Vuze, Miro and uTorrent.

    Interestingly, only those originating from Jamendo seem to work.

    I'm pretty new to Frostwire, but if there is any way I can get to a log I can upload here I'd be more than happy to help.
  • Hi,

    I suggest waiting, the newest release of frostwire will be released soon, in which one of the aims was to help improve frostwire torrenting feature.
  • I am having this issue also. I have upgraded to 4.18.6 with java 1.6.0_17 and am unable to download torrents. Is this a setting or another issue? The status shows waiting for sources. Previously I have been able to download using frostwire.

    Thank you
  • Are you sure the torrent files have available sources?
  • soon all of these issues will go away for good :)
    (stay tuned to the subversion repo and you'll see why)
  • Can you help I am using 4.20.2 with windows xp , Virgin and since upgrading when i try to drag downloads to my desktop as I have always done i get the error message " cannot copy file the name you specified is not valid or too long. Specify a different name." I am doing nothing different to what I have done can you help. Sorry if I have not given all the information but I have never used the forum before
  • http://frostwire.wordpress.com/2010/03/ ... hours-now/

    We're on it (we're actually doing nothing else except fixing this issue)
  • so i started downloading some torrents....and they wont download. all they'll say is "Queued" and won't start. i tried restarting the download..didnt work. any suggestions?
  • are you using FrostWire 4.20.3 ? You should have no issues whatsoever with 4.20.3, downloads everything.
  • I would be thrilled with a Queued or Needs more Sources message. I receive an error message saying the torrent may be malformed or Frostwire does not have permission to access it. This is with torrents that I know work fine with other programs.

    Frostwire has been updated to 4.20.3 and java was updated within the last week.

    Any ideas what is happening? Can you recommend a program that will create a torrent compatible with Frostwire?
  • Skeeter, try the following:

    - Shutdown FrostWire completely
    - Go to your FrostWire preferences folder, inside you'll see a "azureus" folder. Delete it completly (if you have some torrents being downloaded you might want to finish those first, this will delete all information about your torrent downloads)
    - Start FrostWire and try downloading again, the issues should be gone.

    I've come across this issue myself a couple times, but I can't tell what's causing it, pretty much 99% of the of the torrents we test are working fine now.
  • I'm having the same problem as everyone else. I was downloading torrents like a charm until I upgraded to the new version and now all I get is "Locating sources" with EVERY file I try and download, no matter what file I'm trying to download or what site I'm trying to download from. You made reference to going in to the Frostwire preference folder and deleting the "AZUREUS" folder completely in order to solve the problem. Where exactly is the Frostwire "Preference" folder located ? When I open the Frostwire folder under programs I see no "Preference" folder. I see a file "lw-AZUREUS" but no preference folder and no AZUREUS folder.

    Thanks!
  • As a result of Aaron's response to my "Where are the mods?" Thread I was able to locate and delete the "Azureus" folder. I then selected a torrent from the web for downloading and Frostwire kicked in, located sources and immediately started downloading the file even though my connection status in the bottom left of the screen seemed to be hung on "Starting connection" versus getting the "Turbo charge connection" status I'm used to seeing. The file finished downloading successfully and played fine so I thought all was fixed. Not the case though. Now Frostwire will not connect to the network. It stays hung on the "Starting connection" status. All worked fine connection wise until I deleted that "Azureus" folder so while deleting the folder did enable Frostwire to be utilized as my download manager for a bit torrent file I selected from the web it also must have had some kind of adverse affect on being able to connect to the network. Any search I do now from within Frostwire gives me the message that I need to be connected to the network.

    I'm running windows 7, 64 bit. Thanks in advance for helping to resolve this.
  • The "Connection" status represents only the Gnutella Connection Status.

    BitTorrent downloads are independent, there's no handshaking of any sort with ultrapeers, it's all per-torrent basis.

    We need to think of a way to let the user know about that. Maybe the FAQ needs an update.
  • Thanks Gubatron. I undestand what you're saying but can you explain how deleting that folder would have caused the connection problem I'm now having (Connecting was no problem before) and do you know how I can fix it? I did look at other posts regarding connection and tried some of the things mentioned like disconnecting and connecting frostwire and my internet connection multiple times but that did nothing.
  • I'll have to read this thread with more time. But for now the expected behavior is that if you delete the azureus system folder (for frostwire) when FrostWire is restarted it should re-create everything it needs and it should work.

    What I've seen sometimes is that certain versions of the Java Virtual Machine can have issues opening connections and there are options that you can pass FrostWire on startup to help you solve those issues. I'd try installing a newer or an older java virtual machine to see if the connection problems go away. I've experienced myself such issues on Mac when Leopard came out, switching the default virtual machine for a 32-bit or a 64-bit version (can't remember which one did the trick back then) solved the issues.
  • I'm running the latest version of java and my PC is set up to automatically check for and install Java updates as they're released. Up until deleting the the "AZUREUS" folder I was using Frostwire 4.20.6 with the latest Java release perfectly, no connection problems whatsoever. I don't see how this could be a JVM issue? Very frustrating. Any and all additional ideas will be appreciated.

    Thanks!

Leave a Comment