Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Expect a bit of breakage the following days as we adjust to this new platform.

We thank you for your patience.
-FrostWire Team

Very very very slow downloads

Hi. I was wondering if you could tell me how to speed my downloads up. It takes so long I actually end up walking away from my machine and checking to see if it's done the next day. PAINFULLY SLOW. I'm running a Dell Dimension 3100 with Windows XP Home, and a cable internet connection. Please help? I'm getting frustrated here. :x

Comments

  • Does this happen with every single download? Some downloads will be very slow, depending on the speed the other host(s) are uploading ... even if there are a few.

    Can you do a few speed tests at http://www.speakeasy.net/speedtest/ and also tell us, if you can, but this is not essential, what speed your isp says they are providing you with?

    Then I can check if you have your settings correct :)
  • yes, this happens with every download. also searches don't return near as many results as it used to. even common-known songs don't come back with many results. i did some speed tests. quite a few, actually, and it ranges from 1714kbps to 4517kbps for download speeds, with about 2500 kbps being the most common. upload speeds are fairly consistent around 600 kbps. my isp package is for download speeds up to 1Mbps, which i assume is 1000kbps. i feel i should also let you know that in the download window, the speed column always says 0kbps while downloading.
  • I have a feeling that some searches are not getting so many results also...

    as for your speeds ..it seems you are actually getting more than you should, which is a first, lol .. I suggest going into Tools>options>Speed, and selecting T3 then go to Download and set the cursor at 180KBps (which equates to 1440 kbps)
    and in Uploads set the cursor to minimum which should still ensure uploads as fast as you can upload them. You can always change these at any time ...

    A speed registered as 0 KBps simply means it is under 1 KBps ..and yes that is very slow. See if these settings help, and let us know... ..also who is your isp (service provider) ...some of them have their own ideas of what people should use their bandwidth for and p2p is not always one of them.
  • Hello again. I've made the settings changes and nothing is happening. It's just the same, slow, non-results-returning searches and nothing is happening with my downloads. No different. My isp is Persona. "The Amazing Persona" they call themselves.... Thanks
  • Hmm ..a google search on your isp seems to show they are a good company, but You can never be absolutely sure.

    Can you try this. Go to http://www.magnetmix.com/audio2.shtml Magnetmix and download a song ... many don't seem to work but Sleepwalker does. Do not click on the link as it will try to get you to use another application .. drag the link (Download the MP3 "Sleepwalker") into the download window of Frostwire and it should download ... let me know how fast it goes.

    Also tell us which ports you have set for Frostwire in tools>options>advanced>firewall config

    and if you have any router or anything else you can think of which is not standard to your computer.

    Also ...are you new to Frostwire ...or have you used it.. or any other p2p application before with success?
  • i'm having this problem too. & i am a Mac user. please help. i've set my speed to T3 awhile ago, & now it is slow again =[
  • @Guanjyn it would help if you could do a speed test or two as I described earlier in the thread and try the download of a Magnet link as I described also.

    Which computer and OS are you using (apple logo>about this mac) and and also can you tell us if there is any other odd behaviour ... like FW crashing or refusing to quit even if forced to quit.

    and who is your isp, and are you connecting from home or office or college and what country are you in?
  • Macbook OS X 10.4.10

    download speed 2073 kbps
    upload speed 302 kbps

    home, BT Broadband. & i'm in England (London)

    i can't work out that magnet thing btw. is it really important?
  • BT broadband are known to throttle p2p use, at least at busy times, and this might be your problem. Have you tried downloading at different times of day ..or night

    You should have your speed set as T3, but check your download cursor, and set it to about 200KBps, and upload to minimum. The upload speed you have is pretty low, but is what we have come to expect of isps nowadays. Check if that makes a difference.

    The magnet download would certainly help ... I found it a bit awkward to drag the link to Frostwire. It took a few tries :) That should give you a fast speed .... although downloads off the network generally may well not.

    However there is a possible issue with Mac OSX ..especially if you are using an intel model which is why I asked for your computer details ..In particular I did want to know if it is intel or PPC

    If you have intel could you do something for us. Start up Apple's "console" (Applications>utilities) clear it and then run Frostwire for a while and try to download a few things. when you have finished. see if the Console says anything and copy and post the result ... if any.
  • i tried putting the download bar at 200, & the upload to minimum, but it seems like that just made it slower

    & yes it is intel. here is what happened with the console

    ===== Saturday, 29 September 2007 14:22:21 Europe/London =====
    java.lang.ClassNotFoundException: irc.plugin.
    at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:164)
    at irc.IRCApplication.loadPlugin(Unknown Source)
    at irc.IRCApplication.init(Unknown Source)
    at com.limegroup.gnutella.gui.chat.ChatMediator.tryToStartAndAddChat(ChatMediator.java:147)
    at com.limegroup.gnutella.gui.chat.ChatMediator$1.run(ChatMediator.java:106)
    at java.lang.Thread.run(Thread.java:613)
    Event dispatch in wrong thread
    expected thread was [Lirc.DispatchThread;@4eda77
    current thread is Thread[Thread-7,5,main]
    please submit a bug report to bugs@frostwire.com with the following information :
    java.lang.Exception: Stack trace
    at java.lang.Thread.dumpStack(Thread.java:1176)
    at irc.EventDispatcher.dispatchEventSyncEx(Unknown Source)
    at irc.ListenerGroup.sendEventEx(Unknown Source)
    at irc.ListenerGroup.sendEvent(Unknown Source)
    at irc.ListenerGroup.sendEvent(Unknown Source)
    at irc.gui.pixx.PixxTaskBar.enter(Unknown Source)
    at irc.gui.pixx.PixxTaskBar.addStatus(Unknown Source)
    at irc.gui.pixx.PixxMDIInterface.statusCreated(Unknown Source)
    at irc.gui.pixx.PixxMDIInterface.sourceCreated(Unknown Source)
    at irc.IRCApplication.sourceCreated(Unknown Source)
    at irc.IRCServer.enumerateSourcesAsCreated(Unknown Source)
    at irc.IRCApplication.newServer(Unknown Source)
    at irc.IRCApplication.init(Unknown Source)
    at com.limegroup.gnutella.gui.chat.ChatMediator.tryToStartAndAddChat(ChatMediator.java:147)
    at com.limegroup.gnutella.gui.chat.ChatMediator$1.run(ChatMediator.java:106)
    at java.lang.Thread.run(Thread.java:613)
    Event dispatch in wrong thread
    expected thread was [Lirc.DispatchThread;@4eda77
    current thread is Thread[Thread-7,5,main]
    please submit a bug report to bugs@frostwire.com with the following information :
    java.lang.Exception: Stack trace
    at java.lang.Thread.dumpStack(Thread.java:1176)
    at irc.EventDispatcher.dispatchEventSyncEx(Unknown Source)
    at irc.ListenerGroup.sendEventEx(Unknown Source)
    at irc.ListenerGroup.sendEvent(Unknown Source)
    at irc.ListenerGroup.sendEvent(Unknown Source)
    at irc.gui.pixx.PixxTaskBar.activate(Unknown Source)
    at irc.gui.pixx.PixxTaskBar.enter(Unknown Source)
    at irc.gui.pixx.PixxTaskBar.addStatus(Unknown Source)
    at irc.gui.pixx.PixxMDIInterface.statusCreated(Unknown Source)
    at irc.gui.pixx.PixxMDIInterface.sourceCreated(Unknown Source)
    at irc.IRCApplication.sourceCreated(Unknown Source)
    at irc.IRCServer.enumerateSourcesAsCreated(Unknown Source)
    at irc.IRCApplication.newServer(Unknown Source)
    at irc.IRCApplication.init(Unknown Source)
    at com.limegroup.gnutella.gui.chat.ChatMediator.tryToStartAndAddChat(ChatMediator.java:147)
    at com.limegroup.gnutella.gui.chat.ChatMediator$1.run(ChatMediator.java:106)
    at java.lang.Thread.run(Thread.java:613)
  • oh btw, that is all after i opened Frostwire ^^^^^

    & i tried downloading that mp3 you mentioned earlier & it says 3KB/s
  • bump -_______________-

    ps, thanks for all the help you've given so far, unfortunately the issue still remains
  • Hi you are not forgotten, The Forums have been mis-behaving, and so we have not been on much .... I will give you a reply which is hopefully helpful shortly.
  • I agree ... it looks like your isp is throttling p2p ..it would be worth trying to use Frostwire at different times of day and night to see if that makes a difference. Switching isp to NTL or a related company might be worth considering, but these wretched companies do like to tie you into a long contract even if they don't deliver what is expected.
  • so it can't be fixed then?
  • Well if your isp IS throttling p2p use .. and we know they do in many areas ... then the only solution is to change isp. You can ask them directly if they throttle p2p use but the answer you get is likely to be "no". Either because they will not own up to it, or the "PR" expert on the desk will have no idea what you are talking about.

    Have you tried other p2p applications like Limewire or Phex ... It is just possible that one of them might work. Phex is at http://www.phex.org/mambo/


    It appears that FW always gives a console readout like yours on a Mac. It does on mine and it does not affect my speeds.
  • BT are not known for p2p filtering. They do however impose transfer restrictions, up/download too much in one month and they'll limit you the next. It doesn't have to be transfers with frostwire, any internet usage counts.
  • just climbed down to the bottom of your post ....

    Guanjin how do you get on with downloads through your browser? Are these also slow? That would confirm if you are being throttled if, as NP says, BT do not specifically restrict p2p use. I noticed a lot of Google hits on the subject but did not read them too thoroughly ..

    Also .... have you been doing a large amount of downloading recently?
  • they are not slow through my browser. & i tried Phex, but that didn't work well, & Limewire is what i switched from to Frostwire in the first place
  • hey, i went back to Limewire, & it is still slow, just not as slow as Frostwire was. do you know any programs other then those 2 for Mac that will run fast? i know, you probably aren't allowed to promote any other software, but these programs are just horrible :(
  • Phex is a very good programme which I use sometimes and recommend. It is not the most simple to use .. others worth investigating are Acquisition, which is much the same as Limewire/Frostwire, but costs money and Poisoned, which is a multi network client .. no experience with them. There is one called Crosswire which is supposedly based on Frostwire/Limewire. I tried it and hated the interface and it crashed continually.. best avoided,

    but I have a feeling you will have the same problem with all of them ..

    This thread makes interesting reading. I recomend you have a read of it:- http://www.digitalspy.co.uk/forums/show ... p?t=583822 and does, I think, give some pointers to where your problem might lie.
  • lol i had a look on there. i had no idea it was a problem with BT. i'm also on Option 3. maybe BT have got enough complaints about it though & hopefully it should be fixed in time

    thanks for all the support here. i think i'll just wait it out for now

Leave a Comment