Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Expect a bit of breakage the following days as we adjust to this new platform.

We thank you for your patience.
-FrostWire Team


This post is not comprehensive or complete, partly because too much information can confuse, and partly because any useful input/correstions/additions would be more than welcome. If you can contribute please post here, and I'll do my best to keep the post updated and manageable.

It might be a good idea to start with the basics and check CONNECTION TROUBLESHOOTING: then have a look at the rest of this post if you have no luck. TY BindTortureKill :)

If you are not running Frostwire 4.24.4 please update by clicking Home or Downloads above. Note that this version will connect in difficult cases far more often that previous versions, however, initially, it may take quite a while, perhaps 20 minutes or longer. After a possible slow initial start, it should be far quicker in future. Much of what follows should not be necessary with Frostwire 4.18.1 or later, but please give us feedback on any method you find works for you, with a few details. That will help us, and others, in the future.

Note that Frostwire will always indicate it is behind a Firewall if it is not connected ... even if there is in fact no Firewall present.
If you are experiencing connection problems, probably seeing the message: "Starting Connection", go to Frostwire > file > disconect and then back to file > connect. If that does not help, try restarting Frostwire and possibly your internet connection a couple of times, and do give Frostwire several minutes (but no more that ten) to try to connect. If this works, you should not need to do it again. but do please let us know.

In the past, users have often needed to install a fresh file but if you have version 4.17.0 or 1 this should not be necessary. EDIT: - However some users still find this helpful with later versions. If you have an earlier version of Frostwire it may well help you and instructions can be found here: Replacement of file

A possible problem can occur in Windows XP SP 2 chiefly ....
In your start menu click Run...
Type in eventvwr
Press ok and a window (hopefully) opens.
In the system section look for events of type 4226
Windows XP can sometimes trip over it's own feet when using many connections and event 4226 shows this. If you are seeing this then Go to read it all and download and install the "patcher" Thanks to Nonproffessional

ALTERNATIVELY TRY THIS:- In the community chat support channel you can obtain host connections by typing ?connect, and following the instructions, and possibly repeating this a few times, which often helps, as can the team there. If you do connect leave Frostwire running for a good while. This should make it easier to connect in future. If you receive a message saying "Sorry, but no 'hosts' have been found - please try later." please don't go away but wait for someone to help :)

To get to the Community Chat Support Channel: In Frostwire there's a Community Chat tab at the top or you can find it via View > Show/Hide > Community Chat. Just pick a unique nickname and connect, it will automatically stick you into main so just type /join #support in the bar you use to chat and you'll join us in the room [Thanks Calliope :) ]

If your nick is not accepted Type /nick and a new name.

If you succeed in connecting after having problems it is a good idea to leave Frostwire running and working for a few hours. Switching it off after half an hour is not going to ensure it will continue to connect.


Also See Aaron's post HERE < click

and try DJ Maxx's suggestion HERE


If you still have problems after reading and following the suggestions, please start a new thread or return to your previous one, and give us some details of your Operating System, Internet Service Provider, method of connection, modem and router models and numbers, software installations like AV which may be affecting connectivity, previous experiences with Frostwire or other p2p applications and anything else that you think might help. but ...... FIRST PLEASE READ THE FOLLOWING and follow the links I have given.

Please check out the FAQ

In addition:

Reinstalling Java can often help with connecting and other Frostwire problems. (This cannot be done on Mac OS X without a total reinstallation of OS X)
The most thorough way to do this is to first ensure Frostwire is Fully Closed. Then use a program like Revo Uninstaller to completely remove all traces of Java and then to reinstall the latest version using the offline installer from The Java Site.

This method can also be used to completely remove Frostwire prior to making a clean install from the Download Frostwire link above, and doing this with both Java and Frostwire at the same time is, as a rule, best. If you do this, or in fact at any time, it is wise to make a back up of your saved downloaded files on a back up drive or as Data on a CDRom, or at least move the files out of the Frostwire Save Folder to somewhere like your desktop just as a safety precaution.

If you have Tip Of The Day showing, try disabling it in the Help menu.

Check in Frostwire>preferences (Mac) or Tools>options (Windows) >connections>connect on start up ensure box is ticked. If you do not want this option enabled, make sure File >connect is enabled.

Check, again in preferences/options > advanced > performance > Capabilities and check/tick "Disable Ultrapeer Capabilities". Frostwire will usually only connect you as an ultrapeer if you have a good and fast connection, but you lose nothing by connecting as a leaf. If Frostwire is "unsure" if you should connect as an UP connection problems may occur unless this option is disabled. Dissabling the other two options in Advanced > Performance can also improve speed and performance of Frostwire in certain circumstances. If you make changes here you will need to restart frostwire.

Give Frostwire a good 20 minutes or so to connect. It should not take more than a few moments, but be patient if it does not connect immediately.

Possible solutions can be found by deleting the Frostwire Preference or Application Data folder while Frostwire is fully closed.
In Windows C:\Documents and Settings\yourusername\Application Data\FrostWire
The Directory is hidden by default so you must enable "show hidden files and folders"
In Mac: users>your name>Library>preferences>FrostWire
When Frostwire re-starts it will create a fresh folder, and note that re-configuration of Frostwire will be necessary, so make a note of your settings!

If you are starting Frostwire with any downloads in progress, cancel them. you can restart them after Frostwire is fully corrected.

It is known that disconnecting and unplugging your modem totally and reconnecting it after a few minutes can sometimes help a lot.

Windows users in particular should ensure that their hard drive is regularly de-fragmented.



A solution brought up by Vericon, and posted by Gummo to a problem with connecting in Vista..
If you still can't connect after trying the above ideas, you can try right-clicking on the FrostWire icon, before going to Compatibility options and checking the "Run as administrator" option.

Also see a post along similar lines here by sag47: ... =6988#6988
Changing compatibility mode is another solution also explained in the linked thread.

Certain security installations in Vista prevent Frostwire from connecting and it has been found that uninstalling Frostwire and the security programme, then reinstalling Frostwire, and finally the security programme, can cure the problem.

This post by Zappaboss may also help. ... 470#p18470 Please let us know if it does.

Any other thoughts or solutions are more than welcome.


It may be that your Internet Service Provider is blocking or shaping your use of p2p or your bandwidth in general, possibly, just at certain times of day, so it is worth trying to connect late at night when traffic is lower. It is possible that nothing will get you connected, but possibly enabling manual port forward in options>advanced>Firewall config and setting both ports to somewhere in the 55,000 to 60,000 region will help, or so I've heard.

As already said ... feel free to set me right on any of this or add anything that might help.... I have never had a connecting problem myself so this is all I have picked up from others.


  • Hey, I had a major issue connecting to frostwire awhile ago and there were some things I tried and it solved my issue. If the ?connect isnt helping you try these things. (Some of my suggestions may have already been listed, if so forgive the redundency)

    1.)Try Disabling Ultrapeer. This can be found in Tools -> Options -> Speed

    2.) Go to Tools -> Options -> Advanced -> Firewall config and choose the Manual port forwarding option and set that port somewhere in the 55,000 to 60,000 range (redundant) I punched in random numbers, currently being 56904.

    3.)Check on anti-virus software. Most anti-virus programs seem to not effect Frostwire (from what Ive been told) but there could be another issue going on, such as a conflict with 2 programs. Its never safe to leave your computer unprotected, but for the sake of testing this theory, try to uninstall all anti-virus and anti-spyware programs and see if it helps. If it does help then you will know what the problem was. NEVER LEAVE YOUR COMPUTER UNPROTECTED. There are several free programs you can use. I personally recommend AVG. They offer free anti-spyware and anti-virus, which you can find at After I uninstalled my programs I reinstalled both avg products and I have no problems =) So check those out.

    Those are the things I did and now I seem to be running fine. Unfortunatly I did all of those things without testing if any individual one worked but I figured I would post them all anyways. Happy downloading!
  • Go to the Community Chat page, connect there and choose #Support from the room list, when you get in type ?connect and follow the instructions. This seems to be the most effective trick we have.
  • Just wanted to let the community know we installed a UHC server, it's currently under testing, hopefully less and less people will feel the connection problems now that we installed a bootstrapping server.

    We need volunteers to run more instances, we can hand over the binary version of our UHC server and help you configure it.

    Also another (lighttpd) mirror for frostwire downloads has been enabled, it had a configuration error which was leading to 404, but it's now been fixed, so we hope more people will be able to download frostwire without any inconvenients.

    Once again, Thanks to all the people that have made contributions to help us pay for the bandwidth bills.
This discussion has been closed.