Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Expect a bit of breakage the following days as we adjust to this new platform.

We thank you for your patience.
-FrostWire Team

FrostWire will not run on MacOSX 10.7.2

I am running MacOSX 10.7.2 on a 15" Macbook Pro with a Core i5 processor and 8GB of RAM. I downloaded and unpacked FrostWire 5.2.11 and copied the application to my Applications folder. When I run FrostWire, I see the message "FrostWire is unpacking. Will be out in a few seconds...". After a few seconds, FrostWire exits. The menubar goes back to the Finder and Frostwire does not appear to be running when checked using the Activity Monitor. Is there anything I can do about this? I would appreciate any help or suggestions.


  • Is this your first install of Frostwire?

    Did your machine come with Lion installed, or did you upgrade from Snow Leopard?

    Have you run all software updates. If not re-run and install, and then re-run if necc. until no updates are available.

    Please go to Applications > Utilities > Java 0r Java Preferences and tell us what you see there.

    Please Open Applications > Utilities > Console. Clear the console. Try to start Frostwire. Enter Frostwire into the Console string Filter and post the resulting log, if any.

    I thought the Lion compatibility had been fixed .. it looks like possibly not. All information you can give will be very useful.
  • This is my first time to install FrostWire. My MacBook Pro is the Mid 2010 model. It came with Snow Leopard and I upgraded to Lion. I'm running 10.7.2 and Software Upgrade says it is up to date. According to Java Preferences, I'm running Java SE 6, Version 1.6.0_29-b11-402, both 64-bit and 32-bit. The 64-bit version is first in the list.

    Here's what I see in the system log after installing and running FrostWire.

    2011/12/16 1:19:49.993 PM [0x0-0xb40b4].FrostWire: ApplicationAdapter().genericHandler()!
    2011/12/16 1:19:50.806 PM [0x0-0xb40b4].FrostWire: MRJAdapter.pack
    2011/12/16 1:19:50.895 PM [0x0-0xb40b4].FrostWire: commons-logging.pack
    2011/12/16 1:19:50.904 PM [0x0-0xb40b4].FrostWire: frostwire.pack
    2011/12/16 1:19:51.605 PM [0x0-0xb40b4].FrostWire: gettext-commons.pack
    2011/12/16 1:19:51.683 PM [0x0-0xb40b4].FrostWire: gson-1.4.pack
    2011/12/16 1:19:51.721 PM [0x0-0xb40b4].FrostWire: h2-1.3.160.pack
    2011/12/16 1:19:51.902 PM [0x0-0xb40b4].FrostWire: httpclient-4.0.pack
    2011/12/16 1:19:51.978 PM [0x0-0xb40b4].FrostWire: httpcore-4.0.1.pack
    2011/12/16 1:19:52.027 PM [0x0-0xb40b4].FrostWire: lucene-3.4.0.pack
    2011/12/16 1:19:52.297 PM [0x0-0xb40b4].FrostWire: lw-alexandria.pack
    2011/12/16 1:19:52.454 PM [0x0-0xb40b4].FrostWire: lw-azureus.pack
    2011/12/16 1:19:53.768 PM [0x0-0xb40b4].FrostWire: lw-common.pack
    2011/12/16 1:19:53.959 PM [0x0-0xb40b4].FrostWire: lw-osx_stub.pack
    2011/12/16 1:19:53.966 PM [0x0-0xb40b4].FrostWire: lw-resources.pack
    2011/12/16 1:19:54.062 PM [0x0-0xb40b4].FrostWire: lw-setting.pack
    2011/12/16 1:19:54.080 PM [0x0-0xb40b4].FrostWire: messages.pack
    2011/12/16 1:19:54.337 PM [0x0-0xb40b4].FrostWire: splash.pack
    2011/12/16 1:19:54.385 PM [0x0-0xb40b4].FrostWire: substance.pack
    2011/12/16 1:19:54.806 PM [0x0-0xb40b4].FrostWire: trident.pack
    2011/12/16 1:19:54.906 PM [0x0-0xb40b4].FrostWire: MD5: 8c7e0d17c7df67473e4c297fb57c97c5
    2011/12/16 1:19:54.911 PM [0x0-0xb40b4].FrostWire: MD5: 9667a7d1594c58c99eeb139d1866906c
    2011/12/16 1:19:54.993 PM [0x0-0xb40b4].FrostWire: MD5: 6a53cc000ae0563b0b6b77e18e5aaab3
    2011/12/16 1:19:54.994 PM [0x0-0xb40b4].FrostWire: MD5: 5b65c334c289c00e911434ee1e66daee
    2011/12/16 1:19:54.995 PM [0x0-0xb40b4].FrostWire: MD5: b8899e4fafd77b6e6ba5cef95853f033
    2011/12/16 1:19:55.005 PM [0x0-0xb40b4].FrostWire: MD5: bb6afb53cdc7094645b10e55982d55d4
    2011/12/16 1:19:55.007 PM [0x0-0xb40b4].FrostWire: MD5: 75354ace5363b94ba5823a4c49164dca
    2011/12/16 1:19:55.008 PM [0x0-0xb40b4].FrostWire: MD5: 44e19a426a21ec41dadb86f9249db60b
    2011/12/16 1:19:55.019 PM [0x0-0xb40b4].FrostWire: MD5: 3cbef782f88b13c617e38a2050c853be
    2011/12/16 1:19:55.022 PM [0x0-0xb40b4].FrostWire: MD5: 6ef62b972233b5bbf1f6c39ee8e474c2
    2011/12/16 1:19:55.110 PM [0x0-0xb40b4].FrostWire: MD5: 2674697c2b6a778f984cec8d97e11201
    2011/12/16 1:19:55.112 PM [0x0-0xb40b4].FrostWire: MD5: 9f2e37b12a91dae50c34c2cf2401eb1d
    2011/12/16 1:19:55.112 PM [0x0-0xb40b4].FrostWire: MD5: 4af81dc575b5fdfd373c425233edb9be
    2011/12/16 1:19:55.115 PM [0x0-0xb40b4].FrostWire: MD5: d5e2a8b28084cb122bdcc86e4d750809
    2011/12/16 1:19:55.116 PM [0x0-0xb40b4].FrostWire: MD5: 14f8dde79c55ed139053a50290829a80
    2011/12/16 1:19:55.142 PM [0x0-0xb40b4].FrostWire: MD5: 856e28fa2309d7a377bcacb72ec70e2c
    2011/12/16 1:19:55.144 PM [0x0-0xb40b4].FrostWire: MD5: 5d4ac8129d66e56898509a5d5075e417
    2011/12/16 1:19:55.159 PM [0x0-0xb40b4].FrostWire: MD5: 546b7486bed70c7c5c77bd23148a2c21
    2011/12/16 1:19:55.160 PM [0x0-0xb40b4].FrostWire: MD5: cefb414b687a714137d6e3f7064d75b2
    2011/12/16 1:19:55.160 PM [0x0-0xb40b4].FrostWire: Creating hashes file at: /Applications/
    2011/12/16 1:19:55.169 PM [0x0-0xb40b4].FrostWire: FrostWireLauncher.replaceInfoPlist()
    2011/12/16 1:19:55.169 PM [0x0-0xb40b4].FrostWire: cp /Applications/ /Applications/
    2011/12/16 1:19:55.252 PM [0x0-0xb40b4].FrostWire: FrostWireLauncher.main(): Will try relaunch.
    2011/12/16 1:19:55.252 PM [0x0-0xb40b4].FrostWire: FrostWireLauncher.relaunch() invoked
    2011/12/16 1:19:55.262 PM [0x0-0xb40b4].FrostWire: FrostWireLauncher.main() ended.
    2011/12/16 1:19:55.262 PM [0x0-0xb40b4].FrostWire: About to execute /Applications/

    Thanks for your help!
  • can you calculate the md5 of your installer (.dmg) and paste it here?
  • also, that log looks like the console output of the first run ever. can you try running frostwire after that happens one more time and paste the ouput of the log on a second or posterior attempt of launching?
  • I'm running into problems as well:
    Installed Lion, updated JAVA and then re-installed Frostwire.

    When trying to run Frostwire for the first time I get an error message "You can't open the application JavaApplicationStub because PowerPC applications are no longer supported"

    Lion 10.7.2
  • You have not said which Frostwire version you are trying to install. Please tell us.

    Also from your computer details.

    Please click  > about this mac > More info > Processor name

    What Frostwire did you have before and were you running OS X 10.6.8?
  • I was running OS X 10.6.8 before the upgrade to Lion, with the most current version of Frostwire, but I can't remember offhand.

    right now I am using the most current version of Frostwire, updated Java with Apple's Java from their web site.

    Processor 2.4 GHz Intel Core 2 Duo
    Memory 4 GB 667 MHz DDR2 SDRAM
    Graphics Intel GMA X3100 144 MB
    Software Mac OS X Lion 10.7.2 (11C74)

    When I installed the newest version of Frostwire on my friends OS X 10.6.8 it worked fine. I think Lion is being a beast!

    Any suggestions as there appears to be no substitute P2P software I like to use!


  • Well DUH! I looked at the "get info" on Frostwire, and "run 32 bit" was checked off! So I removed the check mark, and it runs.

    The only other thing I did was copy JavaApplicationStub from path -"/System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub" to my application "Content/Resources/Java" as suggested by another post. See below!

    (MAC - JavaApplicationStub compatibility
    by neelam » Wed May 05, 2010 2:25 am)
  • THanks for posting that rcohen04

    I remain happy that I still run OS X 10.6.8 for a number of reasons and if I was buying a new Mac I would insist it did not have Lion installed.
  • Well I can say my system is running fine, and much faster once Lion is installed and I upgraded Contribute CS3 to Contribute CS5, and Parallels 5 to Parallels 7. I had an old version of Corel Draw (V 11) that wasn't used much, and can't run that one any longer. No big deal, otherwise, I'm please with Lion right now. Good luck!

  • Well I guess its cant be all that bad :)

Leave a Comment