Buy VPN - Never trust a VPN Provider that doesn't take Bitcoin
Welcome everybody to the new FrostWire forums.

Make sure to check out our Community Guidelines
http://www.frostwire.com/guidelines

Please be a good neighbor, treat others with respect and patience.
Make friends!

-FrostWire Team

Frostwire 4.21.6 Help Please

I'm running on Frostwire 4.21.6 and I'm having issues. It says I am on a Turbo Charged connection but my downloads are running between 0 - 2 KB/s and sometimes they disconnect completely to "Need More Sources". Can anyone tell me what the problem is? Sorry if this has been posted already. I couldn't find my issue here.

Also, my settings are adjusted to:
Maximum downloads: 100
Maximum Bandwidth: Unlimited

Comments

  • Some downloads will be fast and some slow. It all depends on the speed the other host is able to upload at, and some sharers can be terribly slow.

    You will find that sometimes you will get the need more sources message in these cases and usually clicking resume or search for more sources will get the download running again. This was always an issue with Frostwire 4

    I you can find another search result for what you want, it may well download quicker.
  • The problem is it's doing that with every single thing I download. I'm not understanding why. I can click Restart and it will just keep looking for sources and I can try another file from another user. The files, no matter how big or how small, have been doing that.
  • Could you try two things.

    Click on the "whats new search" and try downloading a few results from there.

    Also go into your connections tab (view > show/hide > connections if you cannot see it).
    Highlight a host and browse host. If you cannot browse, remove the host. When you find a host you can browse, see if you can download a couple of files.

    Let us know how you get on.

Leave a Comment